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Macros\Basic is an application working with OMNIC

Presenter
Presentation Notes
Macros\Basic is a separate application that works in conjunction with OMNIC to automate a sequence of OMNIC operations. This works great when you want to analyze a set of samples and make sure it is done the same way each time.  Macros can be extremely useful to capture a simple series of events for inexperienced operators who need to use the system or for situations in which you want to add assurances that the same procedure is being followed for every sample.

To start Macros\Basic, double-click its icon on the desktop. A new window opens titled Macros\Basic.
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A macro is a sequence of tasks

Presenter
Presentation Notes
Each sequence of events is called a macro. It can be as simple as a single task (Collect Sample) but you would probably not actually do this because you can do the same thing in OMNIC. The real power is to string together a sequence of tasks.

This view shows a the macro editor window and example macro consisting of four tasks.
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Parts of the macro editor window

Task list

Macro editor 
command 

menu

Task search 
box

Insertion 
point

Macro workspace

Task

Readout or 
hints 

displayed here

Scroll 
bar

Presenter
Presentation Notes
The large white area on the right is the workspace. This is where the sequence of tasks is built. Each task is a step in a flow beginning with Start through End. As more tasks are added the workspace fills up and a new page is added. The controls underneath the workspace tell you what page you are on and let you move from page to page.

The Task list fills the left side of the window. Notice the scroll bar on the right of the Task list. Use this control to scroll the tasks list up and down.

The Task search box is located immediately above the task list. Just type the name of the task in this box and click the binoculars to locate the task in the list.

The Macros\Basic editor menu is in the upper left. This is where you find the standard Open, Save , etc. commands as well as some tools and options to help you edit macros.
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The Task list mimics the OMNIC menus

Presenter
Presentation Notes
The Task list contains all of the tasks that can be added to the macro workspace. The task list is grouped in sections which mimic the menus in OMNIC. 

There are a few differences in the list of commands because Macros\Basic was designed to be just that – Basic. Some commands which are used for only advanced techniques have been left out. In addition, some commands just aren’t amenable to being run from a macro because they are interactive.

For example, Advanced Diagnostics is in the OMNIC Collect menu but not in Macros\Basic.
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Adding a task to your macro

Presenter
Presentation Notes
Suppose we want to set the experimental conditions before we collect our sample spectrum.

First, place the insertion point before Collect Sample by clicking the workspace between the Start and Collect Sample tasks. Be sure to click on the workspace not a task. Clicking on a task selects it (turns it black). We’ll talk about that later but it isn’t what we want to do now.

Next, scroll the Tasks list until you find the Open Experiment task. This is a file manipulation type of operation so you will find it in the File section.

Click the task in the Tasks list. It will be added to the macro at the insertion point.
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Different color tasks

Presenter
Presentation Notes
The Collect Background task is added to your macro. Simple eh? Using this technique, you can quickly string together a sequence of commands. 

You have probably noticed some of the tasks have different colors. Can you guess why?

The color lets you know if the task requires additional information in order to run. The color key is as follows:

Red –	These tasks require that you specify additional information about the operation. The macro cannot run unless this information is provided. For example, the Peak Height task requires that you specify which peak you want to measure. We will refer to this additional information as parameters.

Blue –	These tasks have parameters that you MAY specify or set but you are not required to do so. The macro will run just fine without the additional information.

Black –	These tasks have no parameters so you don’t have to do anything with them.

So how do you set the Task parameters to provide the additional information?
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Task parameters

Presenter
Presentation Notes
It’s simple; just double-click the task. Let’s do this for a red task in our example macro – Peak Height.

Two windows or dialogs pop up on the screen; one with the task name and one titled Macro Variables. We will ignore the Macro Variables window for now. Also, the task turns black in the macro workspace so you know which one you are working on.

The task dialog lets you enter the information needed to complete the task. For Peak Height, we need to specify the peak location to measure. This task mimics the OMNIC peak height tool. Recall the Peak Height tool lets you use the Shift key to select the peak in the spectrum to where you click. The Seek closest peak option does the same thing.

Similarly, the OMNIC Peak Height tool reports both uncorrected and corrected peak heights. The corrected peak height is the height above a baseline that you specify with the tool. You can do the same from the macro task by specifying the optional baseline values. If you leave these blank, the uncorrected peak height will be measured.

Finally, there is an option to display the peak height measurement result when the macro runs.

As you write more macros, you will notice that each task has a different parameter dialog because each task performs a different operation. If you have questions about any of the parameters, click the Help button. The on-line help system explains each dialog and its parameters.

For this module, we will set the peak location to 1001 and click the OK button.
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Removing a task

Presenter
Presentation Notes
The additional information is stored in the task and the color of the task changes from red to blue. This indicates the task has all the information it needs to run.

Suppose you want to change your macro by deleting a task or moving it to a different position in the sequence. We’ll use the Report task to demonstrate.

First, click the task to select it. It will turn black when selected. Remember:

Single-click a task to select it (it turns black).
Double-click a task to edit its parameters (a task dialog is displayed).
Click outside a task to move the insertion point.

Second, choose Edit > Clear from the macro editor menu or just press the Delete key. You can also right click the selected task to display the Edit pop-up menu. 
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Cut, Copy, and Paste Tasks

Presenter
Presentation Notes
The Report task is gone leaving the insertion point at its old location.

You can use the same technique to Cut, Copy, or Paste tasks in your macro. Just use the Task select feature (single-click task) followed by the Edit operation. Move the insertion point (single-click the workspace) to indicate where you want the copied or cut task to be placed. Choose Paste. 

As with most Windows style applications, you can use the Shift key to select multiple, contiguous tasks or the Ctrl key to select multiple, separate tasks. Note that you can easily move tasks between pages by using the workspace navigation buttons.
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Save that macro before you go too far

Presenter
Presentation Notes
Before you go too far, it’s a good idea save your macro so you don’t accidently lose your work. Chose File > Save from the Macros\Basic menu.

A standard Windows Save As dialog is displayed. We will save our macro with the original name of My First Macro. You can save the file wherever you like. The standard location is in a folder named Macros within the My Documents > Omnic location.
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Summary Info

Presenter
Presentation Notes
After you click the Save button, a Summary Info dialog is displayed. This is where you may provide an author and comments for your macro. This information is optional.

Click OK to close the Summary Info dialog and complete the save operation.

You have successfully written, edited, and saved your first macro! Now what? I suppose you want to know how to actually RUN the macro …
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Running a macro
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Presenter
Presentation Notes
The easiest way to run a macro is to choose the Macro > Test command in the Macros\Basic editor menu. As the command implies, this is also how you would test a macro while you are editing it.

Macro execution begins immediately. The currently executing task is highlighted (black). Information is also displayed in the Status panel and in the readout area.

Notice that all of the controls in the macro editor window become disabled (greyed-out). The only active control is the Stop Macro button.
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Macro tasks execute the same as OMNIC commands

Presenter
Presentation Notes
As the macro executes, you will see the normal OMNIC prompts just as if you had run the command from the OMNIC menu.

For example, the Collect Sample task can be set to prompt for a spectrum title as shown here. 

Of course, the power of macros is that you can modify this behavior as you see fit by changing the task parameters. In fact, the default setting for Collect Sample is to NOT prompt for a title. Can you guess why?

Answer:
Macros are often written automate repetitive operations. In these cases, you usually want to control the spectrum title by incrementing it (Run #1, Run #2, etc) or perhaps reading the title from a sample log file:

Sample 1: Batch number ABC-123
Sample 2: Batch number ABC-456
Sample 3: Batch number DEF-123
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Ending macro execution

Presenter
Presentation Notes
The normal way a macro ends it by finishing all of its tasks. When this occurs, the Status panel disappears and all controls in the Macro editor window are re-enabled.

Another way to end macro execution is to click the Stop macro button in the status panel. This will ask for confirmation, then stop execution.

The third way to stop a macro is to cancel an operation via an OMNIC Prompt. For example, we may click the Cancel button when the Collect Sample operation prompts for a spectrum title. Macros\Basic detects the cancellation and reports an Error. You then have the option to continue the macro or quit it.
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Assign a macro to the OMNIC toolbar

Presenter
Presentation Notes
Lets return to running a macro …

We talked about running from the Macro editor using the Macro > Test menu command.

We can also assign a macro to the OMNIC toolbar so that we can run the macro without starting Macros\Basic.

To add a macro to the OMNIC Toolbar:

 From the OMNIC menu, choose Edit > Edit Toolbar.
 In the Edit Toolbar window, click the Add item button.
 In the Add Toolbar Item window, select the Item Type option for Run Basic macro.
 Click the Browse button to locate the macro you want to run.
 Click the OK button.






In fact, this is the recommended way to deploy a macro once you have it just the way you want it. All OMNIC installations allow you to run macros – even if the Macros\Basic application is not installed. This gives a central lab the ability to author macros (using Macros\Basic), then to deploy the finished macros to satellite labs without Macros\Basic. 
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Placing the macro on the OMNIC toolbar

Presenter
Presentation Notes
An icon for your macro is created and placed in the User Item field of the Edit Toolbar window.

Choose where you want the macro icon to be placed on your toolbar (target location). Use the scroll bar in the Current Toolbar control (yellow area) to view the toolbar. In this example, I have slid all the way to the right end of the toolbar.

With your target location is in view, click on the User item icon, drag it down to the target location, and release it.

Click the Save button to save this change to your OMNIC configuration file.

Click OK to return to OMNIC.
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Ready to run macro from OMNIC toolbar

Presenter
Presentation Notes
The new macro icon now appears on the OMNIC toolbar. Place the mouse over the icon and it displays the name of the macro.

You are now ready to run the macro from OMNIC. Just click the button and the macro begins execution.

A tiny macro status panel is displayed while the macro runs. This lets you know which operation is executing and gives you the ability to stop the macro if necessary.
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Interacting with a user

Presenter
Presentation Notes
The next couple of topics cover interaction with the operator who is running the macro. We’ll refer to them as the “user”.

It is often helpful to display a message telling the user what is going to occur. Sometimes we need to ask the operator to do something like insert the sample. Or maybe we need to ask for additional information. We’ll cover each of these cases.

First, we will display a message asking the user to place the sample in the instrument. A good time to do this is right before we collect the sample. We move the insertion point before the Collect Sample task then chose Insert > Comment from the macro editor menu. 

While were here in the Insert menu, a brief explanation of the other commands is in order.

Comment – A message displayed to the user when the macro executes.
Program Note – Documentation about the macro that is not displayed.
Decision – A program flow element that displays a choice to the operator.
Loop – A program flow element that repeats execution of a portion of the macro several times.
If…Then… - A program flow element that does one of two things depending on a certain constraint.
Macro – Lets you call (execute) another macro from this one.
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Displaying a message (Comment)

Presenter
Presentation Notes
The menu command Insert > Comment adds a triangular symbol to the macro workspace. It displays a dialog where you can enter the text you want to display.

This macro will be used with a microscope so we give instructions on how to place the sample. Note that you can also enter a title for the caption of the message window – “Insert Sample” in this case.
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This is how a Comment task appears at run time

Presenter
Presentation Notes
When the macro runs, the comment is displayed after the Experiment file is opened and before the Collect Sample task. The macro pauses until the operator clicks the OK button.

Sometimes we want to offer a choice to the user other than just OK. For example, you might want to have an option to Cancel in case the user needs to do something else.

To add more options, use the Decision task. Let’s replace the Comment with a Decision task that lets us cancel the macro.

In the macro editor, select the Comment task (turns black) then choose Decision from the Insert menu. Click Yes when you see the confirmation message asking if you want to overwrite the Comment task.
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Decision task

Presenter
Presentation Notes
The Decision task dialog lets you enter text just like we did for the Comment task. It also lets you enter labels for up to 3 buttons. The macro workspace symbol for a Decision task is a diamond.

You can also specify an action to take place when you click a button. In this case, we attached the Stop Macro task to the Cancel button.

How did we do this? First, click in the Action box next to the button with the Cancel label (Button 2). Then move to the Tasks list in the main macro editor window and click the tasks you want to add. The task or tasks is added to the Actions box.

You will notice the tasks in the Action list are color coded just the same as they are in the macro workspace. Remember if it is red, you have to set parameters associated with the task. To set the parameters, just double-click the task in the Action box.

You can also leave the action box empty as we have done here for the OK button. At run time, clicking the OK will cause no action so the macro proceeds to the next task. Just exactly what we want.
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Decision task at run time

Presenter
Presentation Notes
Here is what our Decision task looks like when the macro executes. It now gives us the option to cancel the macro. The only thing we give up is the ability to change the title of the message dialog; it always says “Macros\Basic – Decision”.

This is a pretty trivial example of the Decision task but hopefully it demonstrates the power you have to control the flow of a macro. You can string together any number of tasks or even call another macro when the user clicks a button.

The key distinction here is the USER interacts with the macro when you use a Decision task. The macro pauses until the user selects what to do next. 

Quite often we want the macro to make a decision itself without stopping and waiting for a dumb user to respond. For example, we may want to increase collection time if a signal is too weak. To do this, we use a If…Then… task Instead of using a Decision task.

But we get ahead of ourselves. Before we can talk about a macro making decisions, we need to understand the concept of macro variables.
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Macro variables

Presenter
Presentation Notes
You remember variable from Algebra class, right? The good news is they don’t have to be that complicated. In Macros\Basic, a variable is a tag that holds a value. The tag is always the letters “mv” followed by a number. For example, mv1, mv2, mv153, or mv65000. As you can see, there can be a LOT of macro variables. Relax, I’ve never seen anyone use more than just a handful.

A macro variable can hold any kind of value; a number, text, or a system constant:

mv1 = 3.14159
mv2 = “sample ABD-123”
mv3 = sysTime

There are many ways to assign a value to a macro variable as we shall see. The simplest is to use the Math task. Here we see the Math task dialog. This dialog lets you define which macro variable you want to assign by typing a number into the mv box. When you add a Math task to a macro, Macros\Basic automatically finds the next available macro variable and inserts this number for you.

The Definition field is where you assign a value to the macro variable. Here we have entered the numerical value for pi. The definition can also be text such as “apples and oranges”. You do NOT need to enclose text in quotes.

The other field is Format. This is primarily for numbers and lets you control the number of significant digits. Suppose you wanted to display just integer (whole) numbers; set the format to “0”. The default format is “?” which lets the system handle things (text or number).

The Math task has a lot more capability; functions, system constants, etc. We won’t get into those topics here but you can use the Help button to learn more and see some examples.

Click OK and the macro variable is defined. Now, when you re-open the Math task, you will see your definition and you will also see the declaration in the small Macro Variable window that we always see pop up.
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Using macro variables

Presenter
Presentation Notes
We have seen how to use the Math task to create a macro variable. The next step is to use a macro variable.

Let’s add a second Math task to our macro. Notice that it automatically comes up as mv2. We’ll multiply the value of mv1 by two and set the format to display just 2 significant digits. Click OK to save the definition.

Notice that when we use a macro variable, the macro variable tag is surrounded by pound signs (#). You can think of the notation #mv1# as “the value of mv1”. When the macro executes, the #mv1# tag is replaced by the current value of the macro variable. In other words, this second math task – at run time – the #mv1# tag is replaced by 3.14159 and we get the equation: 3.14159 * 2.
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More on macro variables

Presenter
Presentation Notes
The same goes when using macro variables with other tasks. For example, let’s add a Comment task to our macro and use the two macro variables we just created.

The run time Comment message is shown here also so that you can see the result. Notice the effect of the format field we used in the second Math task.
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Capturing task results

Presenter
Presentation Notes
Yet another use for macro variables is to capture the result of a task. For example, our first macro which collects a spectrum then measures a peak height. It would be nice to be able to do something with that peak height measurement rather than just display it to the user. Macro variables to the rescue!

In Macros\Basic, there is a special variable named result that automatically stores the result of all tasks that produce results. You can use this result variable in your macro immediately after a task as we have done here with a Comment task.

While the result variable is simple to use, it is not particularly flexible. You get a fixed text string and you may find you need just part of the string. For example, suppose we just the X and Y values so we can take the average of multiple measurement. Fortunately, there is another way to capture the result of a task.
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Store Result task

Presenter
Presentation Notes
The Store Result task lets you store the individual results from a task into separate macro variables. This gives you complete flexibility in using the results later in your macro.

In the Store Result task dialog, you specify the task whose result you want to store. As you select different tasks, you will notice that the Result options change to values appropriate to the task. Here we have selected the Peak Height task and the Corrected peak height value.

We’ll add a second Store Result task to store the Peak location value.
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Using stored results

Presenter
Presentation Notes
We have added a second Store Result task to capture the peak location result and re-written the Comment to include both values. The run time display is included here so you can see the result.

If you have been following along writing your own macro, you will notice that the Corrected Peak Height result requires a baseline in the Peak Height task. We did not show you the steps for specifying the baseline in the Peak Height task. The errors messages you saw should have directed you how to fix this problem. If not, Open the Peak height task now and define the baseline points (1054 and 950 are good values).
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Request task lets the user enter data

Presenter
Presentation Notes
The Request task lets you prompt the user for information. The value entered by the user is stored in a macro variable.

In this example, we ask for the batch number of a sample and then we’ll use it as the title for the spectrum.

The Request task has options to let you read data from a file or extract it from another application like Excel. But these are advanced topics which we won’t cover here.
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If…Then program flow tasks

Presenter
Presentation Notes
Earlier, we saw how a Decision task can be used to control the flow of a macro based on input from the user. Usually, we would like the macro to make this decision for us so that an analysis can be automated. The If…Then task uses macro variables to let us do just that.

For this example, we have a macro that measures the height of two peaks in a spectrum and calculates the peak height ratio. If the ratio is greater than a certain value, we want to do one operation; if not, we want to do a different operation. The tasks shown here measure one peak and store the result into a macro variable then repeat this for the second peak. The math task calculates the ratio and stores the result into a third macro variable.

We are ready to insert the If…Then program flow tasks. Make sure the insertion point (dashed line) is at the end of the macro and choose Insert > If…Then… from the Macro menu.
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Inserting an If … Then task

Presenter
Presentation Notes
You will see three new tasks added to your macro: If…Then, Else, and End If. Each of these tasks has a distinctive flow chart shape to let you know it is a program flow control task.

The If…Then task dialog is also displayed along with the Macro Variables dialog. Notice the field labeled “Execute tasks if:”. Here we enter the condition which determines whether or not the macro executes an operation. In this example, we have entered the expression #mv3# > 0.7.  If the value of macro variable 3 (#mv3#) is greater than 0.7, the expression evaluates to True and the operations immediately following the If…Then task are executed. We’ll call this the If…Then branch.

If the expression evaluates to False, the operations immediately following the If…Then task are skipped and the tasks after the task labeled Else are executed. We’ll call these tasks the Else branch.

Click the OK button in the If…Then task dialog to save the expression.
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Adding tasks to the If…Then branches

Presenter
Presentation Notes
Now that the If…Then program flow structure is added, you can place the insertion point in each branch and add the tasks to execute. Here we have simply inserted a Comment task into each branch. In real life, you will likely want to do something more complex involving many tasks. You can add as many as you like and the macro will continue to grow.

As the macro grows, it fills the page and spills over to an additional page. This is what has happened here. Notice the bottom task now says “Continue” (not “End”) and the page marker below says “Page 1 of 2”. The navigation buttons are enabled and, as you move your mouse over each, a description appears in the readout. The example shown here “Moves forward one page in the macro”. Click the button to see the next page of your macro.
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Moving between pages in your macro

Presenter
Presentation Notes
You now can see the rest of your macro. This is how you use the navigation buttons to move around in your macro as it grows in length.

Also notice the insertion point is on page 2 at the end. There is still only one insertion point in the macro; if you don’t see it on one page, it is on another. Remember, you can click the workspace on any page  of your macro to move the insertion point where you like. This makes it easy to add tasks.
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If…Then at run time

Presenter
Presentation Notes
Lets run the macro we just created so you can see what it looks like at run time.

Does the operation make sense to you? It should. The value of the ratio (#mv3#) is 0.84 which is greater than our condition (0.75). The If…Then expression evaluates to True and the Comment task in the If…Then branch is executed.

One final comment about the If…Then program flow. The Else branch is optional. You may find cases where you don’t want to do anything if the condition is false; just continue the macro. In this case, just select the Else task and delete it. The If…Then function remains but just has the single branch ending with the End If task.

What else can you do with If…Then? 

You can insert one If…Then structure inside the branch of another. This lets you build multiple conditions upon each other.

You can call another macro from a branch. This is a good practice because it makes the macros a bit easier to follow; especially when each branch contains a lot of tasks.

There is a lot of flexibility here. Think about how you might use it to guide your analysis.
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Loops

Presenter
Presentation Notes
Our final topic is loops. A loop lets you execute the same set of tasks over and over again. You will find this useful for any number of analyses.

For example, suppose we want to collect 10 spectra over the course of an hour to follow the progress of a reaction. We could add 10 separate Collect Sample tasks and Delay tasks to our macro but it is much easier to use a loop.

To create a loop in your macro, choose Insert > Loop from the macro editor menu. Two tasks are added: Start of Loop and End of Loop. The Start of Loop dialog is displayed. This is where you indicate how many iterations of the loop you want to execute.

In this example, we set the number of times to execute the loop to 10.  We can also setup the loop to iterate through all spectra in a window or we could use the value of a macro variable as the loop number.

Click OK to close the Start of loop dialog.
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Loop boundaries

Presenter
Presentation Notes
The loop structure is added to the macro. Notice the loop count displayed in the Start of Loop task. This makes it easier for you to check your macro without having to open the Start of Loop task.

The insertion point is between the Start and End of Loop tasks. As you have probably figured out, the two tasks define the boundary of the loop Add as many tasks as you like between the Start of Loop and End of Loop task. They will be executed each time the loop runs.
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Adding tasks to a loop

Presenter
Presentation Notes
In this example, we are collecting 10 spectra with a 5 minute delay between collects.

For the Collect Sample task, we are using the index feature of loops. The loop index is a macro variable which contains the current loop iteration number. Here, we use its value (#index#) as part of the tile of the spectrum. Another popular use for the loop index is to construct a filename (Math task) and use this filename to save spectra as they are collected.
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Running a macro with a loop

Presenter
Presentation Notes
We’ll finish our macro by adding two tasks after the loop completes.

Select Spectrum – The “Select All” option is selected in this task. All 10 spectra are selected in preparation for the next task.

Statistical Spectra – The “Average” and “Y-Axis” options are selected. The average spectrum will be calculated and added to the window.

Run the macro by choosing Macro > Test from the macro editor menu. Notice the macro status panel readout displays the task currently running and the loop iteration number. This helps you gauge the progress of the macro when it is executing tasks within a loop.

As with the If…Then program flow structure, you can put loops within loops to create a wide range of analysis capabilities.
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The End



 
This concludes the Getting Started With Macros module



 
Next…

• Explore the capabilities of the Tasks List
• Task options reflect the same options you have when using OMNIC
• The Utilities section includes tasks to mimic many of the “interactive” functions in 

OMNIC such as Peak Height
• Practice making your own macros
• Start with simple macros and save them as examples to use later 

when building more complex macros
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