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1 Introduction
1.1 Scope

This guide describes additional Windows domain requirements essential for optimizing Chromeleon installations and improving performance.
These include:
· Event IDs indicative of Chromeleon’s performance being hindered by cryptographic requirements
· Adding Chromeleon certificates to the Trusted Root Authentication store
· Disabling the Automatic Root Certificates Update component
Note: This document describes the recommended approach to installing a Chromeleon 7.2 SR5 domain. Thermo Fisher Scientific cannot guarantee that the instructions provided will meet all needs as the installation may differ depending on the security requirements and installation environment of individual customers.
1.2 Target Audience
This document is targeted at the following audience:

· Customers who plan to install a Chromeleon 7.2 SR5 domain, including system owners, quality managers, and IT professionals

· Thermo Fisher Scientific Service and Support staff who perform the tasks described in the Scope section
1.3 Related Documents

The Installation (Documentation) Compass (CM7ID_010) provides the following information: 

· An overview of the available Chromeleon 7 installation documents

· Conventions used throughout the documentation, such as formatting and numbering

· Information on how the documents are distributed

· Trademark and copyright information
2 Cryptographic Services and Optimizing the Performance of Chromeleon
The performance of Chromeleon can be affected by its reliance on the Microsoft Cryptographic Services, in particular to the Microsoft CryptoAPI. The Cryptographic Services are an integral part of the Microsoft Operating System Public Key Infrastructure and provide an essential function to maintain Chromeleon user and data security as well as protecting Chromeleon binaries.  

The Microsoft CryptoAPI relies on digital certificates for authentication. Do the following:

· Establish the relevant trusts within your Certification Authorities.

· Store the necessary certificates correctly.

· Be able to check revoked certificates. 
If digital certificate management is not in place for your domain, the Microsoft Cryptographic Services will attempt to source the relevant information from the Windows Update website. The Update Root Certificates feature in Windows is designed to automatically check the list of trusted authorities on the Windows Update website. If a certificate issued by a certification authority in a PKI that is not directly trusted is presented, the following happens:

1. The Update Root Certificates feature contacts the Windows Update website to see if Microsoft has added the certificate of the root certificate authority to its list of trusted root certificates.
2. The Update Root Certificates feature will make several attempts to establish this connection before timing out. 
3. Chromeleon must wait until this action is complete resulting in significant delays.

We appreciate that in regulated environments all actions are taken to protect the domain. If you want to prohibit external connections but do not have the resources to fully implement your own digital certificate solutions or employ Windows Server Update Services, it is recommended to add the digital certificate(s) of Chromeleon to the Trusted Root Certification Authorities store. This can be managed either directly on the PC or via the Active Directory Group Policy Management of the domain.

If you want to prevent the Update Root Certificates feature from communicating automatically with the Windows Update website, you can turn off this feature directly or by using the Group Policy.
Note: If you are presented with a certificate issued by a root certificate authority that is not directly trusted, and the Update Root Certificates feature is turned off through Group Policy, you can be prevented from completing the action that required authentication. For example, you can be prevented from installing software (including Chromeleon), viewing an encrypted or digitally-signed e-mail message, or using a browser to engage in an SSL session.
3 How to Identify Crypto API Issues
In order to confirm that cryptographic services are the cause of Chromeleon’s performance issues, the Crypto API 2 logs need to be enabled. If specific events with ID 20 and 53 are observed, further action should be taken as described in Section 3.1.
 of this document. 
3.1 Crypto API 2 Logging
You can execute the following steps either on a Chromeleon client or on one of the servers required for Chromeleon. The example below is based on the Chromeleon domain controller server.
3.1.1 Enable CAPI2 log
4. Open the Event Viewer.
5. In the left pane, go to Applications and Service Logs > Microsoft > Windows > CAPI2.
6. Select the Operational log, Figure 1.
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Figure 1: Event Viewer CAPI2 Log
7. In the right pane, under Actions, click Enable Log.
8. Open Chromeleon.
9. Return to the Event Viewer and press F5 to refresh.
10. Search for errors with Event IDs 20 and 53.
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Figure 2: CAPI2 Event ID 20 & 53
11. When complete, disable the CAPI2 log.
4 Chromeleon Digital Certificates
In order to authenticate protected data transmissions of Chromeleon within the Windows domain, Thermo Fisher Scientific can provide digital certificates that must be added to the Trusted Root Certification Authorities store. Use the Thermo.cer certificate for Chromeleon 7.2 SR5 stations and the Dionex.cer certificate for communication with stations using a Chromeleon version < 7.2 SR5.
Note: Before proceeding, consult the IT department to ensure that adding the Chromeleon digital certificates is in accordance with their policies.
This guidance relates to Windows 10 and Windows Server 2012 R2.

4.1 Add Certificates to the Trusted Root Certification Authorities Store for a Local Computer
Administrators is the minimum group membership required to complete this procedure.
12. Right click the Windows Start button, select Run, type mmc, and click OK.
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Figure 3: Opening mmc
13. Go to File > Add/Remove Snap-in.
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Figure 4: Add/Remove Snap-in…
14. Under Available snap-ins, click Certificates > Add. 

15. Under This snap-in will always manage certificates for, select Computer account. 
16. Click Next.
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Figure 5: Certificates Snap-in…
17. Click Local computer, and click Finish.
18. Click OK.
19. In the console tree, double-click Certificates.

20. Expand the Trusted Root Certification Authorities store and right-click the Certificates folder. 
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Figure 6: Certificates Snap-in…
21. Go to All Tasks > Import to import the certificates. 
22. Follow the steps in the Certificate Import Wizard and import the required Thermo Scientific certificates to the Trusted Root Certification Authorities store.
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Figure 7: Certificate Import Wizard
4.2 Add Certificates to the Trusted Root Certification Authorities Store for a Domain
Domain Admins is the minimum group membership required to complete this procedure.
23. Open the Server Manager.
24. In the Server Manager menu bar, click Tools (Figure 8).
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Figure 8: Server Manager
25. Click Group Policy Management. The Group Policy Management dialog opens.
26. In the left pane, expand Group Policy Management, and locate the domain containing the Default Domain Policy GPO.

27. Right-click the Default Domain Policy GPO, and click Edit (Figure 9). 
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Figure 9: Editing Default Domain Policy
28. In the Group Policy Management Editor, go to Computer Configuration > Windows Settings > Security Settings, and click Public Key Policies.

29. Right-click the Trusted Root Certification Authorities store.
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Figure 10: Group Policy Management Editor
30. Click Import and follow the steps in the Certificate Import Wizard to import the certificates.
Note: The group policy is not applied instantly to all PCs following an update. Refresh the Active Directory-based Group Policy settings on all Chromeleon stations.

5 Update Root Certificates
The Automatic Root Certificates Update component is designed to automatically check the list of trusted authorities on the Microsoft Windows Update website. The steps in this section detail how to disable the feature and keep your current root certificates.
This guidance relates to Windows 10 and Windows Server 2012 R2.

5.1 Turn off Automatic Root Certificates Update for a Local Computer
Note: If you change the setting Turn off Automatic Root Certificates Update for a local computer, it may be overwritten by domain policies afterwards.
To perform this procedure, you must be a member of the local Administrators group, or you must have been delegated the appropriate authority.
31. Right click the Windows Start button, select Run, type gpedit.msc, and click OK.
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Figure 11: Opening gpedit.msc
32. If the User Account Control dialog box appears, confirm that the displayed action is what you want. Click Continue.

33. Double-click Computer Configuration > Administrative Templates > System > Internet Communication Management, and click Internet Communication settings, Figure 12.
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Figure 12: Internet Communication settings – Local Group Policy Editor
34. Double-click Turn off Automatic Root Certificates Update, Figure 12.

35. In the Turn off Automatic Root Certificates Update dialog, click Enabled, Figure 13.
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Figure 13: Turn off Automatic Root Certificate Update
36. Click OK.

37. Close the Local Group Policy Editor. 

5.2 Turn off Automatic Root Certificates Update for a Domain
Note: To perform this procedure, you must have the appropriate administrative privileges.
38. Open the Server Manager.
39.  In the Server Manager menu bar, click Tools (Figure 14).

[image: image14.png]A

« Dashboard

Manage

-@1F

Dashboard WELCOME TO SERVER MANAGER

B Local Server
All Servers
AD DS
DHCP

DNS

ﬂ Configure this log

QUICK START

2 Add roles and feaj

File and Storage Services P>
m Hyper-V

w

Add other servers|

4 Create a server grl

View Help
Active Directory Administrative Center
Active Directory Domains and Trusts
Active Directory Module for Windows PowerShell
Active Directory Sites and Services
Active Directory Users and Computers
ADSI Edit
Component Services
Computer Management
Defragment and Optimize Drives
DHCP

DNS
Event Viewer

Group Policy Management

5 Connect this servg

< [T |

ROLES AND SERVER GROUPS

Roles:5 | Servergroups:1 | Servers total: 1

Hyper-V Manager

iSCS! Initiator

Local Security Policy
Microsoft Azure Services
(ODBC Data Sources (32-bit)
‘ODBC Data Sources (64-bit)
Performance Monitor
Resource Monitor

Security Configuration Wizard
Services

System Configuration
System Information





Figure 14: Server Manager
40. Click Group Policy Management. The Group Policy Management dialog opens.
41. In the left pane, expand Group Policy Management, and locate the domain containing the Default Domain Policy GPO.

42. Right-click the Default Domain Policy GPO, and click Edit (Figure 15). 
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Figure 15: Editing Default Domain Policy
43. Double-click Computer Configuration > Policies > Administrative Templates > System > Internet Communication Management. Click Internet Communication settings, Figure 16.
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Figure 16: Internet Communication settings –Group Policy Management Editor
44. Double-click Turn off Automatic Root Certificates Update.
45. Click Enabled in Turn off Automatic Root Certificates Update, Figure 17.
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Figure 17: Turn off Automatic Root Certificate Update
46. Click OK.
47. Close the Group Policy Management Editor. 
6 Chromeleon Activity Check

When you update a third-party product (for example, Windows), it is useful to know whether any of the following Chromeleon actions are active:

48. Running queue(s)

49. Running Smart Startup/Smart Shutdown

50. Baseline monitoring

The Chromeleon Activity Check is a stand-alone command-line program which checks if Chromeleon related systems are ready for installation/update. You will find the program (ChromeleonActivityCheck.exe) on the installation medium in the Tools > Chromeleon Activity Check folder. 

Note: The Activity Check program requires Microsoft .NET 4.0 or higher. However, it does not require a Chromeleon license or a Chromeleon system login.

To start the activity check:

51. On your installation medium, go to Tools > Chromeleon Activity Check.

52. Copy the ChromeleonActivityCheck.exe file to a location of your choice. 

53. Open the Windows Command Prompt.

54. Navigate to the location of the ChromeleonActivityCheck.exe file and run the program.

55. The following exit codes can be returned:

0: indicates that all Chromeleon actions are inactive

1: indicates active Chromeleon actions

You can use the wait command w to specify a wait time (minutes) for the Chromeleon actions to become inactive. The program will check for active actions every 5 seconds until the wait time has elapsed. The program will exit as soon as the actions have become inactive or after the wait time has elapsed.

Example 1: 

ChromeleonActivityCheck.exe /wait:5 

or 

ChromeleonActivityCheck.exe /w:5

The program will check the system status for active actions every 5 seconds over a wait time of 5 minutes.

Example 2:

ChromeleonActivityCheck.exe /w:-1

The program will check the system status for active actions every 5 seconds infinitely until the system becomes inactive.

Example 3:

You can create a text file, for example ParamList, which includes predefined options for the command.

ChromeleonActivityCheck.exe @ParamList

The program will read the options from the ParamList file. The content of the file may look like this: /w:5.[image: image18.bmp]
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