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Thermo Fisher Scientific

Customer dongle update fails

Issue

customer dongle update fails with error message “another update must be installed first”

Environment

Krios G3i

Resolution

These are possible resolutions for the issue:

  • re-apply previous dongle update file first, then apply new update file

Cause

These are possible causes for the issue:

  • previous dongle update was not fully applied

Details

Original problem was that the customer dongle was missing the license for “TEM AutoCTF PhasePlate activation”. This was reported to Orderdesk Acht (NLEIN.Order-desk-Acc@thermofisher.com) who confirmed that the item is missing and provided a new customer dongle update file.

The update file on the system failed with error “another update must be installed first”.

We logged into the Sentinel server and compared the contents of the previous update with the current customer dongle status on the system, then found that several items of the previous update file were not enabled.

We asked to run the previous customer dongle update first, then the “new” update, then the problem was solved.

Error message during customer dongle update (“new” update file)
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