Skip to main content
Thermo Fisher Scientific

Installation of Xcalibur 4.5 (and later versions) without Xcalibur_System account

Issue

  • “Thermo Foundation Acquisition Service” do not start after IT “touched” the PC
  • Customer provided PC for instrument and “Thermo Foundation Acquisition Service” do not start
  • Customer provided PC for instrument and installer for Foundation or Xcalibur or TraceFinder does not install correctly all components.
  • Some configured instruments are showing status “Server Failed” after IT “touched” PC

Environment

Xcalibur 4.5 and later versions.

Resolution

Thermo released a new version of Xcalibur 4.5 with Foundation 3.1SP8, which has the capability to run without the Xcalibur_System account. Default configuration is still using the Xcalibur_System account. Installation with suppressed Xcalibur_System account must be done in specific way. This procedure can be used for fresh installation as well as, for upgrades of existing installations.

Analysis

IT policy in some companies does not accept local accounts in the Administrators group. Due to this instrument PCs cannot be connected to the local network. This has multiple consequences, like low security of acquisition PC, problems with backups, clunky laboratory workflow.

Cause

Common trigger point for all issues is that IT connected PC into the local domain and applied domain policies which caused crash of software. Presence of symptoms can be changed based on the exact software version and based on exact customer domain policy.

 

 

  • Was this article helpful?