Skip to main content
Thermo Fisher Scientific

Lo P1 Error on Thermoflex 900/1400/2500 Chiller

Issue

Thermoflex 900/1400/2500 chillers displays the "Lo P1" error on the LCD display

Environment

  • iCAP 6000
  • iCAP 7000
  • iCAP Q
  • iCAP Qnova
  • Thermoflex 900/1400/2500 Chiller

Resolution

  • To release the trapped air, use the steps below.
  • If releasing trapped air does not resolve the issue, try these actions:
    • Replace the water flow sensor
    • Confirm that the correct voltage is applied to the Thermoflex chiller (e.g., 115 V or 220 V).
  1. Detach the water sensor.
  1. Unscrew the water sensor connector and clean the connector of any debris that may have accumulated.
  1. With the Thermoflex chiller’s water flowing, press on the water valve until water is flowing out of the valve. 
 
  1. Reattach the water sensor connector and water flow sensor and confirm that the “Lo P1” error no longer occurs.
 

Cause

It is possible that air is trapped at the pressure sensor, especially if you notice that water flows into the reservoir before the "Lo P1” error is displayed.