New iCAP instrument installations and new computer iTEVA SQL loading issues
Issue
- New iCAP instrument installations and new computer iTEVA/SQL loading issues.
- SQL access denied, won't run and/or can't create a database.
Environment
- iCAP 6500 Radial
- iCAP 6500 Dual
- iCAP 6300 Radial
- iCAP 6300 Dual
- iCAP 6200 Dual
- iTEVA release 9.0 or higher
- Windows
Resolution
Verify proper computer setup and required user rights and follow these steps:
- Users signed on to the iTEVA computer must have "Power" or "Administrator" rights. iTEVA readme indicates to load the software you must be signed on with Administrator rights.
- See Installation Manual, Setting up the PC instrument network connection.pdf, and verify communications setup and possible firewall setup issues.
Alternative Firewall set-up: Alternatively after iTeva has been installed you can add all iTeva executables using the Windows Firewall dialog (Start->Control Panel->Windows Firewall). Goto the exceptions page and select Add program, where the iTeva executables can be selected.
Note: Customers company Firewalls need to be set up by their IT people to allow iTEVA to communicate.
Under C:\Program Files\Thermo\iTEVA ...
- an.exe
- CheckALDs.exe
- FeatureRequest.exe
- Publisher.exe
- PublisherDbI.exe
- tspec32.exe
- UNWISE.EXE
- userinfo.exe
Note: Dual Core Processors can be left ON. ONLY IF Autosampler communications seem to hang. Can test try turning OFF HyperThreading and/or Dual Core Processors (found and done in the BIOS).
- Make sure Google Desktop has been turned OFF or un-installed.
- Make sure AutoUpdates are turned OFF.
- Make sure IT does NOT have any hidden remote access / spyware active, like "log me in" or GoToMy PC. Switch it OFF.
- Other optional programs that will crash iTEVA and typically inhibit communications are EMBASSY Trust Suite and F-Secure. Remove them.
Cause
User rights
Regardless of Admin rights, all Users had to be overridden to Full control.
Using Windows Explorer drill down to Thermo directory, right click for Properties, select Security and set to allow full control and access for all users, then SQL database issues were resolved.
Re-install O/S
Final course of action was to reload windows from scratch.
Restored the operating system to its original state using restore disks, Windows XP/SP2.
Installed SQL and iTEVA 9.1 and immediately tested the database creation function, which worked normally.
Transferred his original database files back into iTEVA and they connected successfully and I was able to access them and pull up data from them.
Continued updating windows to the latest service pack and when everything was complete, new database files were able to be created within the database manager.
Un-install and re-install
Un-install and reload resolved problem, SQL works now and database was able to be created. Previous install had reboot issues and the computer wouldn't come up, but after multiple attempts it did finally boot up. Regardless, SQL wouldn't run. If a proper reboot / restart did not occur, it's possible the software did not completely install and/or register properly.