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Thermo Fisher Scientific

Plasma Interlock Green but Plasma is Off

Issue

Can't light plasma, the software believes the plasma is already lit. 

Environment

  • iCAP 6000/7000 Series

Resolution

  1. Inspect the IO board for any signs of damage or malfunction. If necessary, replace the IO board with part number 842315550491.
  2. Drain and replace the chiller water. Ensure the water conductivity is within the acceptable range 
  3. Check the status of the plasma in iTeva and the manufacturing software. If the software shows that the plasma is lit, despite not having started, proceed to the next step.
  4. Attempt to turn off the plasma from iTeva. If you receive an error message (E2199) indicating that the plasma failed to extinguish, continue to the next step.
  5. Check the power readings on the instrument. If the power shows abnormal values or is blank, continue to the next step.
  6. Inspect the control board for any signs of damage, particularly around the RF port and 6.3A fuse. If scorching is present, it indicates a potential issue with the RF interface or RF board.
  7. Order replacement RF interface and RF boards if necessary.
  8. Install the new RF generator and RF interface PCB.
  9. Power on the instrument and verify that the plasma can be successfully lit.

Cause

The root cause of the issue is likely due to an erroneous signal being sent by either the RF interface or RF board, possibly originating from the fiber optic connection. This is supported by evidence of scorching around the RF port and 6.3A fuse on the control board. Replacing the RF generator and RF interface PCB resolved the issue.

 

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