Qtegra Freezing During Run
Issue
Users have reported that the LabBook on their iCAP PRO system is freezing during the analysis of the first sample. This issue occurs without any warning or error messages, causing disruption in the analysis process. The LabBook can be stopped and reinitialized without having to close and re-open Qtegra.
Environment
- iCAP PRO
Resolution
Run the Qtegra software as administrator by locating Qtegra in Start Menu, clicking on More and then selecting Run as administrator. This will allow the firmware for the camera to be successfully updated.
Analysis
This issue occured after the Qtegra software had been upgraded from 2.14 to 2.18 SR1.
The LabBook would freeze after acquiring data some data. For example, the Axial-iFR data may have been acquired for replicate 1 but nothing after that. In the log file it can be discerned whether data was returned for a replicate of a view (given an id number) by the statement "Integrated sent to data system" being present. In this case the view after that indicated that it was aborted.
Kronos.Instrument.Camera.Interface|Debug|Received Exposure with id=83, Type=Integrated sent to data system.|
Kronos.Instrument.Camera.Interface|UserWarning|Current exposure id=84 of overall 1 waiting in queue will be aborted.|
After reviewing the log file further, it was determined that the firmware for the camera did not successfully update after upgradng Qtegra from Qtegra 2.14 to 2.18 SR1
2024-03-12T14:21:01.1081577-05:00|D-DTD8XP3|NT AUTHORITY\SYSTEM|ControlManagerService|iCAPPRO.Instrument|UserWarning|Camera firmware revision 211130 is too old, supported version is 230215. This version will be automatically updated. Please wait...|Camera firmware revision 211130 is too old, supported version is 230215. This version will be automatically updated. Please wait...
2024-03-12T14:21:01.1121575-05:00|D-DTD8XP3|NT AUTHORITY\SYSTEM|ControlManagerService|Kronos.Instrument.Camera.Interface|Info|Camera firmware will be updated...|
2024-03-12T14:21:01.1131572-05:00|D-DTD8XP3|NT AUTHORITY\SYSTEM|ControlManagerService|Kronos.Instrument.Camera.Interface|Error|Error while updating the firmware with file 230215_appfw_1405_1777462369_git6d797c2c_PLM2014429_K.exe: System.Net.Sockets.SocketException (0x80004005): An attempt was made to access a socket in a way forbidden by its access permissions|
Cause
The firmware from Qtegra 2.14 was out of sync with newly installed version Qtegra 2.18 SR1.