Skip to main content
Thermo Fisher Scientific

Qtegra Locks Up When Accessing Autosampler Plugin

Issue

When Accessing the Autosampler plugin (ASX-7400 in this case), Qtegra freezes up and must be closed using Task Manager.

Environment

  • iCAP Qnova Series
  • iCAP Pro 
  • iCAP 7000 Series

Resolution

Enable the MSMQ features using this knowledge article as a guide to do so: Microsoft Message Queue Server - MSMQ - Features

Analysis

Upon inspecting the log file, the following error was observed at the time the autosampler plugin was trying to be accessed in the Dashboard:

"StatusHubMessages are faster received than they can be processed. This is an indication of problem which should be fixed."

Upon inspection of the HubService log file, the following error in reference to the message queue was observed:

"Fatal Error! A message queue (private$\IMHTKronos.CoreStatusClient309b50b9-d787-401f-bc03-fc79cf66e4d3) stopped dequeuing its messages. This message queue is now killed"

Cause

In this case 3 automatic Windows update had occurred before the issue started occurring and since the last time the customer was able to run successfully. It is a good idea to disable Automatic updates (Disabling Automatic Updates in Windows 10) and instead manually install them one-by-one, each time verifying operation of the software after doing so.