No Communication with ESI Autosampler in Qtegra
Issue
No Communication with ESI Autosampler in Qtegra
Environment
- SC2-DX
- SC4-DX
- SC8-DX
- SC16-DX
Resolution
1. Close out of Qtegra, Instrument Control, Configuration and/or ESI software
2. Restart the computer
3. Power cycle autosampler by turning it off for 15s and then turning it back on
4. Open ESI software and click Initialize
Note: The ESI software can be downloaded here: SC Software | ESI Support (icpms.com)
5. Wait for Autosampler Initialized and Instrument Comm Port Opened to appear
6. Close ESI software
7. Open Qtegra and load configuration that has autosampler in it
Analysis
The two specific use cases in which this workaround was successfully used were in situations where the Qtegra software had been upgraded to 2.14 or 2.18 which utilizes the 2.10.10.052 ESI plugin. Also, the autosamplers were 2019 builds. The year of manufacture can be identified by looking at the serial number of the autosampler For example, a serial number of X4DX-19xxxx would indicate that autosampler was manufactured in 2019 based on the numerical values in bold.
Cause
The ultimate cause of the communication issue which prompted the workaround in both of these situations was a faulty ECU which ultimately needed to be replaced.